1 2 Previous Next 17 Replies Latest reply on Jun 27, 2007 3:42 PM by Adrian Brock

    WARNING: Deployer changes

    Adrian Brock Master

      This is warning that I'm just about to commit the deployer refactoring changes.
      Don't resync with trunk unless you want a broken build until I give the all clear. :-)

        • 1. Re: WARNING: Deployer changes
          Paul Gier Master

          I changed the groupId of the microcontainer modules from "jboss"
          to "org.jboss.microcontainer" to better fit maven standards, and make the repository more hierarchically organized.. Looks like this conflicting with the changes you added. Sorry about the bad timing. Should I switch back to the old groupId? Or if you change the new poms, it should fix the issue.

          • 2. Re: WARNING: Deployer changes
            Adrian Brock Master

            Just my luck.

            Nobody has committed anything (except docs) for a week
            then just as I start importing and commiting pgier decides to refactor the maven
            with warning. :-(

            Now I've got to figure out what's been done and fix it.

            • 3. Re: WARNING: Deployer changes
              Adrian Brock Master

               

              "pgier" wrote:
              I changed the groupId of the microcontainer modules from "jboss"
              to "org.jboss.microcontainer" to better fit maven standards, and make the repository more hierarchically organized.. Looks like this conflicting with the changes you added. Sorry about the bad timing. Should I switch back to the old groupId? Or if you change the new poms, it should fix the issue.


              It's OK, I'll fix it. I need to do a full clean checkout anyway to make sure my
              commits all went correctly and the build still works properly
              (Obviously it doesn't currently because of the conflict between our commits :-)

              • 4. Re: WARNING: Deployer changes
                Adrian Brock Master

                Having problems with snapshots again.
                I was trying to create snapshots for the lastest microcontainer trunk
                but then it started giving me messages about missing artifacts.

                NOW I CAN'T EVEN BUILD!!!

                e.g. I get this error message:

                [INFO] Failed to resolve artifact.
                
                Missing:
                ----------
                1) org.jboss.microcontainer:jboss-container:jar:2.0.0-SNAPSHOT
                
                 Try downloading the file manually from the project website.
                
                 Then, install it using the command:
                 mvn install:install-file -DgroupId=org.jboss.microcontainer -DartifactId=jboss-container \
                 -Dversion=2.0.0-20070627.182024-2 -Dpackaging=jar -Dfile=/path/to/file
                
                 Path to dependency:
                 1) org.jboss.microcontainer:jboss-aop-mc-int:jar:2.0.0-SNAPSHOT
                 2) org.jboss.microcontainer:jboss-kernel:jar:2.0.0-20070627.182024-2
                 3) org.jboss.microcontainer:jboss-container:jar:2.0.0-20070627.182024-2
                
                ----------
                1 required artifact is missing.
                
                for artifact:
                 org.jboss.microcontainer:jboss-aop-mc-int:jar:2.0.0-SNAPSHOT
                
                from the specified remote repositories:
                 central (http://repo1.maven.org/maven2),
                 jboss-snapshots (http://snapshots.jboss.org/maven2),
                 repository.jboss.org (http://repository.jboss.org/maven2/),
                 snapshots.jboss.org (http://snapshots.jboss.org/maven2/),
                 jboss (http://repository.jboss.org/maven2)
                


                Which is true, that snapshot does not exist:
                http://snapshots.jboss.org/maven2/org/jboss/microcontainer/jboss-container/2.0.0-SNAPSHOT/
                so why it is trying to retrieve it?

                How do I fix this?

                • 5. Re: WARNING: Deployer changes
                  Adrian Brock Master

                  Besides that the build was working before I tried uploading snapshots.
                  I'm not sure whether others will be affected by this snapshot problem?

                  • 6. Re: WARNING: Deployer changes
                    Paul Gier Master

                    I found a problem in the managed module which is fixed now. Does that fix the problem for you?
                    Are you building "mvn install" from the parent directory?

                    • 7. Re: WARNING: Deployer changes
                      Adrian Brock Master

                      As a test, I tried blowing away my .m2/reposistory/jboss
                      but that's just made things worse.

                      jboss-aop is referencing the old jboss group id for the microcontainer
                      so it fails to download for a different reason?

                      [INFO] snapshot jboss:jboss-aop:2.0.0-SNAPSHOT: checking for updates from snapshots.jboss.org
                      [INFO] snapshot jboss:jboss-aop:2.0.0-SNAPSHOT: checking for updates from jboss-snapshots
                      Downloading: http://snapshots.jboss.org/maven2//jboss/jboss-aop/2.0.0-SNAPSHOT/jboss-aop-2.0.0-20070604.133637-7.pom
                      6K downloaded
                      Downloading: http://repository.jboss.org/maven2//jboss/jboss-parent/2/jboss-parent-2.pom
                      7K downloaded
                      [INFO] snapshot jboss:jboss-container:2.0.0-SNAPSHOT: checking for updates from snapshots.jboss.org
                      [INFO] snapshot jboss:jboss-container:2.0.0-SNAPSHOT: checking for updates from jboss-snapshots
                      Downloading: http://snapshots.jboss.org/maven2//jboss/jboss-container/2.0.0-SNAPSHOT/jboss-container-2.0.0-20070614.151456-1.pom
                      3K downloaded
                      [INFO] snapshot jboss:jboss-microcontainer:2.0.0-SNAPSHOT: checking for updates from snapshots.jboss.org
                      [INFO] snapshot jboss:jboss-microcontainer:2.0.0-SNAPSHOT: checking for updates from jboss-snapshots
                      Downloading: http://snapshots.jboss.org/maven2//jboss/jboss-microcontainer/2.0.0-SNAPSHOT/jboss-microcontainer-2.0.0-SNAPSHOT.pom
                      [WARNING] Unable to get resource from repository snapshots.jboss.org (http://snapshots.jboss.org/maven2/)
                      Downloading: http://snapshots.jboss.org/maven2/jboss/jboss-microcontainer/2.0.0-SNAPSHOT/jboss-microcontainer-2.0.0-SNAPSHOT.pom
                      [WARNING] Unable to get resource from repository jboss-snapshots (http://snapshots.jboss.org/maven2)
                      [INFO] ------------------------------------------------------------------------
                      [ERROR] BUILD ERROR
                      [INFO] ------------------------------------------------------------------------
                      [INFO] Failed to resolve artifact.
                      
                      GroupId: jboss
                      ArtifactId: jboss-microcontainer
                      Version: 2.0.0-SNAPSHOT
                      
                      Reason: Unable to download the artifact from any repository
                      
                       jboss:jboss-microcontainer:pom:2.0.0-SNAPSHOT
                      
                      from the specified remote repositories:
                       central (http://repo1.maven.org/maven2),
                       jboss-snapshots (http://snapshots.jboss.org/maven2),
                       repository.jboss.org (http://repository.jboss.org/maven2/),
                       snapshots.jboss.org (http://snapshots.jboss.org/maven2/),
                       jboss (http://repository.jboss.org/maven2)
                      


                      • 8. Re: WARNING: Deployer changes
                        Adrian Brock Master

                        In fact, I don't see any jboss:jboss-microcontainer here?
                        http://snapshots.jboss.org/maven2/jboss/
                        Wasn't there something at some point?

                        • 9. Re: WARNING: Deployer changes
                          Adrian Brock Master

                          I'm also seeing a number of errors like this:

                          [WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for jboss/jboss-test/1.0.3.GA/jboss-test-1.0.3.GA.pom - IGNORING
                          Downloading: http://repository.jboss.org/maven2//jboss/jboss-logging-log4j/2.0.2.GA/jboss-logging-log4j-2.0.2.GA.pom
                          2K downloaded
                          [WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for jboss/jboss-logging-log4j/2.0.2.GA/jboss-logging-log4j-2.0.2.GA.pom - IGNORING
                          Downloading: http://repository.jboss.org/maven2//jboss/jboss-common-core/2.0.2.GA/jboss-common-core-2.0.2.GA.pom
                          3K downloaded
                          [WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for jboss/jboss-common-core/2.0.2.GA/jboss-common-core-2.0.2.GA.pom - IGNORING
                          Downloading: http://repository.jboss.org/maven2//jboss/jboss-logging-spi/2.0.2.GA/jboss-logging-spi-2.0.2.GA.pom
                          2K downloaded
                          [WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for jboss/jboss-logging-spi/2.0.2.GA/jboss-logging-spi-2.0.2.GA.pom - IGNORING
                          Downloading: http://repository.jboss.org/maven2//jboss/profiler/jvmti/jboss-profiler-jvmti/1.0.0.CR5/jboss-profiler-jvmti-1.0.0.CR5.pom
                          392b downloaded
                          [WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for jboss/profiler/jvmti/jboss-profiler-jvmti/1.0.0.CR5/jboss-profiler-jvmti-1.0.0.CR5.pom - IGNORING
                          [INFO] snapshot jboss:jboss-parent:2-SNAPSHOT: checking for updates from jboss
                          


                          • 10. Re: WARNING: Deployer changes
                            Adrian Brock Master

                             

                            "pgier" wrote:
                            I found a problem in the managed module which is fixed now. Does that fix the problem for you?
                            Are you building "mvn install" from the parent directory?


                            Nope.

                            • 11. Re: WARNING: Deployer changes
                              Paul Gier Master

                               

                              "adrian@jboss.org" wrote:
                              In fact, I don't see any jboss:jboss-microcontainer here?
                              http://snapshots.jboss.org/maven2/jboss/
                              Wasn't there something at some point?


                              There is a snapshot for container (http://snapshots.jboss.org/maven2/jboss/jboss-container/) and the other modules, but I don't think the parent pom was ever deployed to the snapshot server.

                              I did a clean checkout and build with an empty local repository, and the build seems ok to me now. Is it still failing for you?

                              • 12. Re: WARNING: Deployer changes
                                Adrian Brock Master

                                 

                                "adrian@jboss.org" wrote:

                                Missing:
                                ----------
                                1) org.jboss.microcontainer:jboss-container:jar:2.0.0-SNAPSHOT
                                
                                 Try downloading the file manually from the project website.
                                
                                 Then, install it using the command:
                                 mvn install:install-file -DgroupId=org.jboss.microcontainer -DartifactId=jboss-container \
                                 -Dversion=2.0.0-20070627.182024-2 -Dpackaging=jar -Dfile=/path/to/file
                                
                                 Path to dependency:
                                 1) org.jboss.microcontainer:jboss-aop-mc-int:jar:2.0.0-SNAPSHOT
                                 2) org.jboss.microcontainer:jboss-kernel:jar:2.0.0-20070627.182024-2
                                 3) org.jboss.microcontainer:jboss-container:jar:2.0.0-20070627.182024-2
                                
                                ----------
                                1 required artifact is missing.
                                



                                I think the problem is that it is getting confused.
                                There is a 182024-2 for jboss-kernel, but that is not what the jboss-container
                                snapshot version is.

                                I'd guess it is leaking version numbers across artifacts?

                                • 13. Re: WARNING: Deployer changes
                                  Paul Gier Master

                                   

                                  "adrian@jboss.org" wrote:
                                  I'm also seeing a number of errors like this:

                                  
                                  [WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for jboss/jboss-test/1.0.3.GA/jboss-test-1.0.3.GA.pom - IGNORING
                                  Downloading: http://repository.jboss.org/maven2//jboss/jboss-logging-log4j/2.0.2.GA/jboss-logging-log4j-2.0.2.GA.pom
                                  2K downloaded
                                  


                                  Some of these dependencies are missing .md5 files in the repository. I'll take a look and add these where I see missing ones.

                                  • 14. Re: WARNING: Deployer changes
                                    Adrian Brock Master

                                     

                                    "pgier" wrote:

                                    I did a clean checkout and build with an empty local repository, and the build seems ok to me now. Is it still failing for you?


                                    Ok, yes. I blew away my entire local repository and now the build works again. :-)

                                    This is the third time I've had this kind of problem, there's definitely some dodgy
                                    bug in the repository code somewhere....

                                    1 2 Previous Next