• Highlights the date in rich:calendar

    Hello Guys I have a calendar which is working fine. it displays records on click and changes the colour to green or red. if records are available date will become red colored. I don't want onclick I want it displa...
    Profile Photo
    last modified by Asim Shaikh
  • how to migrate setPropertyActionListener in rich:autocomplete

    In migration process, I encounter a trouble, it's setPropertyActionListener in autocomplete. I had changed the component name and do migrate mostly successfully, but I was blocked by setPropertyActionListener. Pleas...
    Profile Photo
    last modified by Lu Han
  • Richfaces 3.x file upload is not working in firefox

    Hi,   I am using Richfaces 3.3 along with jboss seam on jboss server. The file upload component works fine on chrome but the same component throws error on firefox browser and following is the stack trace, Could...
    Profile Photo
    created by Manish Prajapati
  • Showing form while data is loading.

    Hello:- I want to show the form on my JSF Website. The should contain one gif file and a label on which "loading" is written. you can view it's sample on http://www.whatmobile.com.pk/ How this can be done using Rich...
    Profile Photo
    last modified by Syed Muhammad Ali Naqvi
  • Disable select all (ctrl+a) in rich extendedDataTable

    Hallo All,   I want to prevent all elements in the extendedDataTable to be selected with ctrl+a. Any workarounds for this?   Thanks     Yannick
    Profile Photo
    last modified by Yannick Feuzet
  • JSF 2.2 + RichFaces 5.0.0-SNAPSHOT - IllegalArgumentException

    I have an application running on Wildfly 8.1 (JSF 2.1) which uses RichFaces 5.0.0-SNAPSHOT and I'm trying to migrate to EAP 7 (JSF 2.2). All my requests are throwing an exception. Any ideas on how to overcome this p...
    Profile Photo
    last modified by rodrigo graciano
  • <rich:editor> is rendering empty

    I am trying to include the <rich:editor> in my jsf page. I am getting the below error and jsf page output rendered empty space in place of <rich:editor> tag. Searched in web to find the root cause but not ...
    Profile Photo
    last modified by Rao Potla
  • Allowflash is not working, Wildfly 9x

    Hello, I am using Wirefly 9x on my proyect. I use richfaces and am trying to enable multiple upload enabling flash but error ocurres when I do that. I tried to debug but the listener is not even called. When I disabl...
    Profile Photo
    last modified by vicent Ros
  • Issue with Jboss 4.3.2 to wildlfy  8.2.1

    Hi,   When i am clicking on UI ,sometime i am getting the following exception. Can someone help with this.   2018-06-12 06:07:56,106 ERROR [org.apache.myfaces.lifecycle.PhaseListenerManager] (default task-...
    Profile Photo
    created by Abhi Kt
  • How to call a java method after successful file upload using <rich:fileupload> tag

    Hi All,   I am new to richfaces and right now, am stuck with a problem. I am using JBoss seam 2.2.2 in my application. The application I have a requirement to execute a java method once I upload a file successfu...
    Profile Photo
    last modified by Aman Painuly
  • Richfaces showcase site service down

    Hi JBoss staff, I tried to visit richfaces showcase yesterday , but it has a 503 error. And I get the same problem today too. Is it the showcase site will end of service or it will be restart again? Hope someone can...
    Profile Photo
    last modified by lokman chu
  • RichFaces + Mobile

    Hello, I am a front-end web dev who needs to make a project at work responsive. The situation is such that the project uses richfaces 3.3.1. I have googled around and found this article ( Getting Started With Mobil...
    Profile Photo
    last modified by Igor Entaltsev
  • Richfaces 3.3.3 doesn't support jQuery 1.9.1 after post back!

    Hello,   We have an application with jsf 1.2, richfaces 3.3.3, seam 2.1.2, this application was developed (most backend) but recently we have received frontend work with bootstrap 3 , jquery (required 1.9.1). ...
    Profile Photo
    last modified by itay sahar
  • a4j commandLink not working with in a4j repeat

    Here is my code :            <a4j:repeat ......>        <rich:datatable>        <rich:column> &...
    Profile Photo
    last modified by krish naik
  • I have a web application build on  latest versions of jsf,richfaces,tomahwak,spring,hibernate,weblogic. The application works fine on click of the tabs or button but sometime hangs and shows blank  page in the UI and when refreshes it works.Need the app

    I have a web application build on  latest versions of jsf,richfaces 4.5.7,tomahawk,spring,hibernate,weblogic 12.2.1. The application works fine on click of the tabs or button but sometime hangs and shows blank...
    Profile Photo
    last modified by techie savee
  • Richfaces page shows blank page sometimes

    Hello Guys, Richfaces page is not loading sometimes, we see blank page (quite randomly). We do see that server response is completed (see this in logs "AFTER RENDER_RESPONSE 6"). But the page is not loading. This occ...
    Profile Photo
    last modified by Parthiban Kumar
  • Rich:tree getData() for selection question

    Hey folks, I know there are a number of posts on rich:tree, but couldn't find anything to answer the problem. I cannot get data from tree nodes passed to events to get the data for the selected node. I don't know whe...
    Profile Photo
    last modified by Andy Gibson
  • RichFaces 4.5.17

    Hi,   My project currently uses the RichFacses 4.3.1 and uses the following jars:   richfaces-components-api-4.3.1.Final richfaces-components-ui-4.3.1.Final richfaces-core-api-4.3.1.Final richfaces-core...
    Profile Photo
    last modified by Pallav Bora
  • rich:orderingList scroll is not moving while changing the list order

    I am trying to move the selected value in the list up and down. I am able to move the value (up& down) respectively, but the scroll bar is not moving along with the value. Can anyone suggest how to resolve this is...
    Profile Photo
    last modified by Bala Maddipati
  • An invalid request "http:///" in RichFaces 3.3.3 when page is refreshed

    Hi All,   We are facing a bizarre issue. Our application is built in JSF 1.2 and RichFaces 3.3.3 (final). We have observed that while refreshing a page on Windows 7 & IE 11; an invalid request (http:///) is ...
    Profile Photo
    last modified by Sandeep Wadhwa